Registrieren / Anmelden
Simulator Forum Handbuch https 
Forum :: Fehler und Probleme

 

Aktuelle Zeit: Di Sep 25, 2018 12:59 pm

Alle Zeiten sind UTC + 1 Stunde


Forumsregeln


Die Forumsregeln lesen



Ein neues Thema erstellen Auf das Thema antworten  [ 67 BeitrĂ€ge ]  Gehe zu Seite 1, 2, 3, 4, 5  NĂ€chste
Autor Nachricht
 Betreff des Beitrags: Verbindungsproblem zum Server
BeitragVerfasst: Mo Nov 06, 2017 8:59 am 

Registriert: Do Sep 08, 2016 10:31 am
BeitrÀge: 143
Hallo zusammen, seit gestern Nachmittag, ca 17 Uhr, kann ich mich nicht mehr zum Kommunikator verbinden. Hab die bisherigen Downloads gelöscht. Neu gedownloadet, Cache gelöscht etc.
Jedesmal bleibt der Test jetzt bei STS-Zeitserver hĂ€ngen (auf rot) und in der Zeile steht dann etwas mit "java.net...." access denied. Alle anderen Punkte sind auf GrĂŒn. Leider kann man das Fenster nicht vergrĂ¶ĂŸern vom Test um diese Zeile vollstĂ€ndig lesen zu können. An meinem System hab ich keine VerĂ€nderungen vorgenommen. Bin jetzt echt ein wenig ratlos.

Die Consolenmeldung spuckt folgendes aus:

Code:
Build: 5666
Java: 1.8.0_131; OpenJDK 64-Bit Server VM
Runtime: OpenJDK Runtime Environment; 1.8.0_131-8u131-b11-2ubuntu1.16.04.3-b11
Arch: 64; running on amd64; 4 cores
OS: Linux; version 4.4.0-98-generic
VM Memory: 2670 MB max; 605 MB used
User: Kohletender UID: 33413
IPv6: false



6., 08:52:21
Build: 5666


Nach oben
 Profil
  
 
Mit Zitat antworten  
 Betreff des Beitrags: Re: Verbindungsproblem zum Server
BeitragVerfasst: Mo Nov 06, 2017 12:51 pm 

Registriert: Fr Feb 12, 2016 5:55 pm
BeitrÀge: 23
Hallo, habe das gleiche Problem gehabt, auch seit gestern. Ich habe die jnlp-Datei und das Manifest in der JAR-Datei angeschaut, und in beiden wurde eigentlich nach all-permissions gefragt, daher konnte ich den Fehler nicht nachvollziehen. Vielleicht ein Bug in icedtea-netx? Aber irgend eine Änderung am Simulator gestern muss das wohl ausgelöst haben.

Ich konnte mir behelfen, indem ich im Programm "IcedTea Web Control Panel" unter "Richtlinieneinstellungen" auf den Button "Einfacher Editor" geklickt habe, dort auf den Button "Neue Codebasis hinzufĂŒgen", als URL habe ich "http://www.stellwerksim.de/" eingetragen und dann fĂŒr diesen neuen Eintrag den Haken "Netzwerkzugriff" gesetzt.

Mir ist aber nicht klar, warum das nötig ist. Auch ein Löschen der icedtea-Konfigurationsdateien im home-Verzeichnis hat nur dazu gefĂŒhrt, dass beim nĂ€chsten Start des Simulators erneut um die Erlaubnis gebeten wurde, auf Dinge auf dem Rechner zuzugreifen, aber dann die gleiche Access-Denied-Exception kam. Wenn du Stellwerksim im Terminal ausfĂŒhrst (mit " cat ~/.local/share/applications/javaws/StellwerkSim* " siehst du in der Zeile "Exec=", welcher Befehl dafĂŒr nötig ist) siehst du eine vollstĂ€ndige Variante der Exception, aber das war irgendwie auch nicht hilfreich.

Wahrscheinlich fehlt es mir an Ahnung zu JNLP / Java Webstart, um das zu kapieren.


Nach oben
 Profil
  
 
Mit Zitat antworten  
BeitragVerfasst: Mo Nov 06, 2017 3:48 pm 

Registriert: Fr Nov 24, 2006 4:40 pm
BeitrÀge: 5
Hallo,

ich spiele seit Jahren Stellwerksim und erhalte seit gestern beim initialen Funktionstest die Fehlermeldung "STS Zeitsystem Verbindungsfehler: access denied ("java.net.SocketPermissi...". Den Rest kann ich leider nicht lesen, weil sich das Fenster nicht vergrĂ¶ĂŸern lĂ€sst. Nur diese Ampel ist auf rot, alle anderen sind grĂŒn. Vorgestern ging es noch einwandfrei. Ich verwende Linux Mint, die letzte Systemaktualisierung war am 2.11. 23.05 Uhr (danach lief Stellwerksim noch einwandfrei). Danach habe ich einiges versucht, das Problem zu lösen (alten Download entwertet, Java de- und erneut installiert), leider ohne Erfolg. Hier die Ausgabe der Analyse auf der Java-Console:

Build: 5666
Java: 1.8.0_131; OpenJDK 64-Bit Server VM
Runtime: OpenJDK Runtime Environment; 1.8.0_131-8u131-b11-2ubuntu1.16.04.3-b11
Arch: 64; running on amd64; 4 cores
OS: Linux; version 4.10.0-38-generic
VM Memory: 860 MB max; 542 MB used
User: xxxxxxx UID: XXXXX
IPv6: false

User und User-ID habe ich unkenntlich gemacht. Die lange Ausgabe bei Start der JNLP-Datei im Terminal versende ich ggf. als private Nachricht, da sie lang ist.

Gruß

Joachim


Zuletzt geÀndert von oberrheiner am Mo Nov 06, 2017 4:12 pm, insgesamt 1-mal geÀndert.
Beitrag verschoben.


Nach oben
 Profil
  
 
Mit Zitat antworten  
 Betreff des Beitrags: Re: Verbindungsproblem zum Server
BeitragVerfasst: Mo Nov 06, 2017 4:35 pm 

Registriert: Do Okt 15, 2009 1:56 pm
BeitrÀge: 3
Wohnort: Wien
Ich habe das selbe Problem, auch mit Linux Mint.
Ich freue mich aber, dass ich nicht der einzige bin :D


Nach oben
 Profil
  
 
Mit Zitat antworten  
 Betreff des Beitrags: Re: Verbindungsproblem zum Server
BeitragVerfasst: Mo Nov 06, 2017 5:01 pm 

Registriert: Fr Feb 12, 2016 5:55 pm
BeitrÀge: 23
endour hat geschrieben:
Ich konnte mir behelfen, indem ich im Programm "IcedTea Web Control Panel" unter "Richtlinieneinstellungen" auf den Button "Einfacher Editor" geklickt habe, dort auf den Button "Neue Codebasis hinzufĂŒgen", als URL habe ich "http://www.stellwerksim.de/" eingetragen und dann fĂŒr diesen neuen Eintrag den Haken "Netzwerkzugriff" gesetzt.


Hier nochmal mein temporĂ€rer Notbehelf fĂŒr das Problem, falls das durch die Topic-Zusammenlegung untergegangen ist!

Falls das "IcedTea Web Control Panel" unter anderen Desktopumgebungen als Gnome 3 oder Unity nicht so leicht zu finden ist: Mittels Konsole lĂ€sst es sich ĂŒber den Befehl "itweb-settings" starten.


Nach oben
 Profil
  
 
Mit Zitat antworten  
 Betreff des Beitrags: Re: Verbindungsproblem zum Server
BeitragVerfasst: Mo Nov 06, 2017 5:06 pm 

Registriert: Do Sep 08, 2016 10:31 am
BeitrÀge: 143
@endour: Vielen Dank! Das war die Lösung des Problems. Das einzige was mich allerdings noch stört, ist, dass man im Controllpanel unter Netzwerkzugriff, dies nicht dirket auf einen Port und ein Protokoll beschrÀnken kann. Da muss ich mich mal schlau machen, wie man das manuell hinbekommt.

Zitat:
Problemlösung von endour:

Ich konnte mir behelfen, indem ich im Programm "IcedTea Web Control Panel" unter "Richtlinieneinstellungen" auf den Button "Einfacher Editor" geklickt habe, dort auf den Button "Neue Codebasis hinzufĂŒgen", als URL habe ich "http://www.stellwerksim.de/" eingetragen und dann fĂŒr diesen neuen Eintrag den Haken "Netzwerkzugriff" gesetzt.


Nach oben
 Profil
  
 
Mit Zitat antworten  
 Betreff des Beitrags: Re: Verbindungsproblem zum Server
BeitragVerfasst: Mo Nov 06, 2017 5:13 pm 

Registriert: Fr Feb 12, 2016 5:55 pm
BeitrÀge: 23
Das freut mich! :-)

Eigentlich sollte der Stellwerksim aber nach der Nachfrage beim ersten Start die nötigen Rechte schon besitzen, und unter Windows funktioniert das ja, ebenso lief es bis gestern und Linux problemlos. Daher wundert es mich, dass diese manuelle Freigabe zusĂ€tzlich nötig ist. Ich habe da gestern auch bestimmt eine Stunde rumgerĂ€tselt. Vielleicht weiß das Entwicklerteam, was gestern alles am Code / dem Packaging geĂ€ndert wurde und kann es so eingrenzen.

Wegen der ein wenig grob geratenen generellen Netzwerkfreigabe mache ich mich keine wirklichen Sorgen, denn das Programm lĂ€uft sowieso mit "all-permissions"-Rechten. Das darf also eigentlich alles, was es so dĂŒrfen will. "If the all-permissions element is specified, the application has full access to the client machine and local network. All JAR files must be signed. The user is prompted to accept the certificate and agree to run the application."


Nach oben
 Profil
  
 
Mit Zitat antworten  
 Betreff des Beitrags: Re: Verbindungsproblem zum Server
BeitragVerfasst: Mo Nov 06, 2017 8:26 pm 

Registriert: Do Okt 15, 2009 1:56 pm
BeitrÀge: 3
Wohnort: Wien
Super, das funktioniert! Danke!

Liebe GrĂŒĂŸe
Johann


Nach oben
 Profil
  
 
Mit Zitat antworten  
 Betreff des Beitrags: Re: Verbindungsproblem zum Server
BeitragVerfasst: Mo Nov 06, 2017 10:09 pm 

Registriert: Fr Aug 10, 2012 3:01 pm
BeitrÀge: 1
Hatte das selbe Problem unter Debian. Dank des Workaround von endour klappt es wieder, danke!


Nach oben
 Profil
  
 
Mit Zitat antworten  
 Betreff des Beitrags: Re: Verbindungsproblem zum Server
BeitragVerfasst: Di Nov 07, 2017 2:05 pm 

Registriert: So Aug 24, 2014 1:38 pm
BeitrÀge: 97
Wohnort: Wien 1220
Hallo, hab auch die Probleme, Spiel startet nicht. Hab Java jre8u151 und sts-manfr(8).jnlp.
Keine Ahnung, was es jetzt wieder ist. Hilfe , kann jemand helfen.
L.G. aus Wien

_________________
Heute beginnt der Rest Deines Lebens.
Udo JĂŒrgens + 2014


Nach oben
 Profil
  
 
Mit Zitat antworten  
 Betreff des Beitrags: Re: Verbindungsproblem zum Server
BeitragVerfasst: Di Nov 07, 2017 2:33 pm 
EntwicklerStellwerk-Mod

Registriert: Do Aug 07, 2008 12:53 pm
BeitrÀge: 1440
Hast du denn schon das ausprobiert, was hier oben steht?
Wenn ja, wÀren etwas mehr Infos schon nicht schlecht um helfen zu können.


Nach oben
 Profil
  
 
Mit Zitat antworten  
 Betreff des Beitrags: Re: Verbindungsproblem zum Server
BeitragVerfasst: Di Nov 07, 2017 2:47 pm 

Registriert: So Aug 24, 2014 1:38 pm
BeitrÀge: 97
Wohnort: Wien 1220
Ich probiere alles aus, aber wie komme ich zu dem Programm "Iced Tea Web?"

_________________
Heute beginnt der Rest Deines Lebens.
Udo JĂŒrgens + 2014


Nach oben
 Profil
  
 
Mit Zitat antworten  
 Betreff des Beitrags: Re: Verbindungsproblem zum Server
BeitragVerfasst: Di Nov 07, 2017 5:31 pm 

Registriert: Do Sep 08, 2016 10:31 am
BeitrÀge: 143
Hier: https://icedtea.classpath.org/wiki/IcedTea-Web#Getting_IcedTea-Web

Musst halt die Passende Version fĂŒr Dein Betriebssystem suchen.


Nach oben
 Profil
  
 
Mit Zitat antworten  
 Betreff des Beitrags: Re: Verbindungsproblem zum Server
BeitragVerfasst: Di Nov 07, 2017 6:09 pm 

Registriert: So Aug 24, 2014 1:38 pm
BeitrÀge: 97
Wohnort: Wien 1220
Danke, gibt's diese Seite auch auf Deutsch?

_________________
Heute beginnt der Rest Deines Lebens.
Udo JĂŒrgens + 2014


Nach oben
 Profil
  
 
Mit Zitat antworten  
 Betreff des Beitrags: Re: Verbindungsproblem zum Server
BeitragVerfasst: Di Nov 07, 2017 6:42 pm 

Registriert: Do Sep 08, 2016 10:31 am
BeitrÀge: 143
Versuch mal die Suchmaschine Deiner Wahl mit den Stichworten "Iced Tea Webstart + deutsche Version + Dein Betriebssystem". Danke.


Nach oben
 Profil
  
 
Mit Zitat antworten  
BeitrĂ€ge der letzten Zeit anzeigen:  Sortiere nach  
Ein neues Thema erstellen Auf das Thema antworten  [ 67 BeitrĂ€ge ]  Gehe zu Seite 1, 2, 3, 4, 5  NĂ€chste

Alle Zeiten sind UTC + 1 Stunde


Wer ist online?

Mitglieder in diesem Forum: LamaAlpen2001


Du darfst keine neuen Themen in diesem Forum erstellen.
Du darfst keine Antworten zu Themen in diesem Forum erstellen.
Du darfst deine BeitrÀge in diesem Forum nicht Àndern.
Du darfst deine BeitrÀge in diesem Forum nicht löschen.

Suche nach:
Gehe zu:  
Powered by phpBB® Forum Software © phpBB Group
Deutsche Übersetzung durch phpBB.de
Impressum